Tarih:31 March, 2020

Functions.php on Line 73 WordPress Hata Çözümü

Yakın zamanda wordpress ‘in yeni sürümü yayınlandıktan sonra çoğu kullanıcı güncelleme sonrası wordpress ‘in yeni teması ya da güncel kullandığı tema da  “Warning: Use of undefined constant REQUEST_URI – assumed ‘REQUEST_URI’ (this will throw an Error in a future version of PHP) in C:\xampp\htdocs\wp\wp-content\themes\twentysixteen\functions.php on line 73” yukarıdaki gibi bir hata ile karşılaştı. Nitekim bende wordpress kullanıcı olduğumdan sorunun çözümünü ilk etapta araştırmayıp eski bir tema kullanmaya devam ettim. Sonraki günlerde localhost üzerinde bir çalışma yaparken aynı sorun karşıma tekrar çıktığında çözümünü araştırma gereği duydum. Sorunun çözümü çok basit olduğundan sizlerle de paylaşmak istedim. Kullandığınız tema ya da wordpress ‘in güncel temasında functions.php dosyasında 73 numaralı satıra gelip vereceğim kodlar ile değişiklik yaptığınızda sorunun ortadan kalktığını göreceksiniz.

Hatalı Olan Kod;

$path = $_SERVER[‘HTTP_HOST’] . $_SERVER[REQUEST_URI];

Hatasız Olan Kod;

$path = $_SERVER[‘HTTP_HOST’] . $_SERVER[‘REQUEST_URI’];

functions.php dosyasının 73 numaralı satırında ki hatayı bu şekilde düzeltmiş olacaksınız.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.